korider.com | Hyosung Motorcycle Owners Forum

korider.com | Hyosung Motorcycle Owners Forum

  • November 22, 2017, 03:52:12 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search

News:

Welcome to Korider.com!

Pages: [1] 2 3 4

Author Topic: Red FI Light  (Read 3359 times)

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Red FI Light
« on: September 08, 2015, 12:52:45 AM »

Hi,

I recently replaced the clutch plates and radiator on my bike then when I took it for a ride after a couple of kilometers the FI light came on and was flashing FI on the screen.

Bike still seemed to ride ok but I took it home straight away. Tried again a couple of days later and same thing.

I checked the charging system at idle and warm etc and it seems to be performing quite well. (Read that somewhere)

Anything else I should check?

Regards,
Andrew
Logged
2012 GV650 Aquila Sport EFI

Register and log in and the Ads below will be gone! :D

BikeBandit.com

umop-ǝpisdn

  • Global Moderator
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 6540
Re: Red FI Light
« Reply #1 on: September 08, 2015, 01:41:27 AM »

Is it giving you an error code, cXX where XX is a number?
Logged
I used to be a sensitive, new age guy, but times have changed and now I am more of a caring, understanding, ninties type.

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #2 on: September 08, 2015, 03:14:04 AM »

Hmmm no I didn't see any error codes.
Logged
2012 GV650 Aquila Sport EFI

Hylife

  • I ride & I vote.
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 2568
Re: Red FI Light
« Reply #3 on: September 08, 2015, 12:16:47 PM »

The service manual explains how to display the error codes.
http://www.hyosung.hu/download/pdf/letoltesek.htm

Once you turn off the key the error codes are lost.
You need to rig up a simple switch to the dedicated socket (see manual) and have it hanging outside the seat so that when a FI light has flashed you can flick the switch to close the socket contacts without having to turn off the engine.

Once you get  the code the manual will assist you with what it means and then you will know where to look for either a loose wire or bad sensor.
« Last Edit: September 08, 2015, 12:18:33 PM by Hylife »
Logged
2011 GV250 - 2011 GV650C - It's not 'what' you ride, it's 'that' you ride.

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #4 on: September 08, 2015, 02:02:05 PM »

Holy crap I haven't seen that manual before, that's a good one.

Also didn't know how to rig the switch thing for bringing up codes. Now I do.  8)

Lets see if I can find some time to give that a try tomorrow.
Logged
2012 GV650 Aquila Sport EFI

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #5 on: September 11, 2015, 01:48:45 AM »

So I rigged up a switch for 'dealer mode' and went for a ride.

The only way I could get the code to come up is by doing this:
1. Flick switch to On
2. Turn on the bike
3. Go for a ride, wait for the FI light to come on indicating an error
4. With the FI light on, hold down the Select button until the time disappears and the error code is shown (approx 15 seconds)

Afterwards the time came back and the speedo changed to cHE and stayed like that until the bike was turned off.

I got the code 05 63, which is nothing like the codes in the manual you linked... Is there a different ECU in later GV650s that could give codes like this or have I shorted the wrong wires haha?

Otherwise if you happen to know what code is for, that's great. :)
« Last Edit: September 11, 2015, 02:24:28 AM by hydrax »
Logged
2012 GV650 Aquila Sport EFI

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #6 on: September 12, 2015, 11:06:08 AM »

Well I took it for a ride today and there was no lights or errors.

I'll keep an eye on it and at least I have the switch ready now for when there is an error. (Hopefully I'll get a helpful code  :) )
Logged
2012 GV650 Aquila Sport EFI

Hylife

  • I ride & I vote.
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 2568
Re: Red FI Light
« Reply #7 on: September 16, 2015, 11:19:39 AM »

Quote
Well I took it for a ride today and there was no lights or errors

Great. Often FI errors are caused by power fluctuations caused by either battery charge issues or a loose/bad connection somewhere from a sensor.
Water from pressure washing can sometimes get into where it is not wanted and make drama but once dried out things return to normal.
Logged
2011 GV250 - 2011 GV650C - It's not 'what' you ride, it's 'that' you ride.

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #8 on: September 16, 2015, 11:44:07 AM »

Yer I figured maybe I didn't plug the fan or temp sensor back in properly or something so I did reseat those connections.

I've been riding all week now without an issue so happy days.

Looking forward to some new tyres on Saturday now. :)
Logged
2012 GV650 Aquila Sport EFI

hydrax

  • Regular rider
  • ***
  • Offline Offline
  • Posts: 120
    • My Youtube Channel
Re: Red FI Light
« Reply #9 on: October 16, 2015, 11:53:37 PM »

So the past week the Red FI Light is on almost all the time now, and checking for the code it always comes up with 05 63, which isn't in that services manual. Bike runs as normal for about 20 minutes or so then it starts to loose a lot of power at take offs (or low revs).

I have a set of spark plugs I've been meaning to install and its also overdue for an air filter replacement, hoping that might help.
Logged
2012 GV650 Aquila Sport EFI

Pages: [1] 2 3 4