korider.com | Hyosung Motorcycle Owners Forum

korider.com | Hyosung Motorcycle Owners Forum

  • November 19, 2017, 09:15:34 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search

News:

Welcome to Korider.com!

Pages: [1]

Author Topic: turn signals wont work  (Read 279 times)

D09hyo

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 14
turn signals wont work
« on: October 26, 2017, 03:13:40 AM »

So i really dont know what else to check. i have stock front turn signals, and led rear  turn signals with resistors. out of the blue, not only are they not working but the green turn signal lights on the display doesnt even light up. usually if a bulb is bad itll blink fast on the display, but nothing is turning on at all. i checked under the seat and the relay is working, i can feel it clicking with each push of the turn signal switch. front bulbs are good, but even if they were bad the display would still function.... right? odd for all 4 to not work. i checked a fuse under rear seat (not sure what that fuse is even for but figured id check it) and fuse is fine. any ideas?
Logged

Register and log in and the Ads below will be gone! :D


Hylife

  • I ride & I vote.
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 2567
Re: turn signals wont work
« Reply #1 on: October 26, 2017, 10:25:17 AM »

Could be a failed relay.
The clicking just means that the flip-flop inside is working, but the connections internally may be gone.
Get your multimeter out and check that there is power coming on-off-on-off etc from the relay output terminals.
Logged
2011 GV250 - 2011 GV650C - It's not 'what' you ride, it's 'that' you ride.

D09hyo

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 14
Re: turn signals wont work
« Reply #2 on: October 27, 2017, 06:44:49 AM »

oh i didnt know that. guess shows how much (or little) i know about relays. ok, i'll check that. thank you!
Logged

D09hyo

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 14
Re: turn signals wont work
« Reply #3 on: October 29, 2017, 02:54:18 AM »

Could be a failed relay.
The clicking just means that the flip-flop inside is working, but the connections internally may be gone.
Get your multimeter out and check that there is power coming on-off-on-off etc from the relay output terminals.

dude! thats EXACTLY what it was. thanks a bunch.
Logged

Pages: [1]