korider.com | Hyosung Motorcycle Owners Forum

korider.com | Hyosung Motorcycle Owners Forum

  • October 22, 2018, 02:14:08 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search

News:

Welcome to Korider.com!

Pages: 1 [2]

Author Topic: Pop! Smoke... but everything still works...  (Read 527 times)

Zyton

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 14
Re: Pop! Smoke... but everything still works...
« Reply #10 on: June 13, 2018, 01:08:25 PM »

Sounds like a backfire out the carbs

Sent from my SM-G950F using Tapatalk

Logged

Register and log in and the Ads below will be gone! :D


spit051261

  • Grinding the pipes
  • *****
  • Online Online
  • Posts: 1168
Re: Pop! Smoke... but everything still works...
« Reply #11 on: June 13, 2018, 01:11:29 PM »

Sounds like a backfire out the carbs

Sent from my SM-G950F using Tapatalk
I concur
Short and straight to the point.
The way our readers like it  ;)
Logged
2010  GT650R in the best colour RED

eliross

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 13
Re: Pop! Smoke... but everything still works...
« Reply #12 on: June 13, 2018, 02:51:41 PM »

Oh it's definitely electrical. It reeked of burnt electronics and it fizzled and burned for a bit (why I booked it for an extinguisher). Hopefully I'll get the tank off tomorrow and I can explore further.
Logged

Joss

  • Scraping the pegs
  • *****
  • Offline Offline
  • Posts: 906
    • Website
Re: Pop! Smoke... but everything still works...
« Reply #13 on: June 14, 2018, 08:19:38 AM »

I just remembered my helmet traffic cam was on so here are some action shots for your entertainment
I could not stop laughing at this, I'm so looking forward to the next set of pictures  ;D.

Does the harness also run down the left hand side of the bike (sat on it) on the GV 650's too? If thats the case the smoke would be from the other side so it might not be the "main" harness.
Logged

eliross

  • Training Wheels
  • *
  • Offline Offline
  • Posts: 13
Re: Pop! Smoke... but everything still works...
« Reply #14 on: June 15, 2018, 03:31:10 AM »

I stand corrected! I decided to swap out the air filter while I had the tank off and, low and behold, the filter was cooked. To be fair it does smell like burnt electrics (I used to work in IT and I'm very familiar with this smell.) So it was a carb backfire, the question is is should I be concerned about one backfire on ignition and get the carbs cleaned, and valves and timing checked? I'm a little concerned about what was burning after the backfire. Thanks guys you've been a ton of help! Pics for entertainment. Just to remind you that's the engine facing side of the air filter
https://ibb.co/eqYsAJ]
Logged

umop-ǝpisdn

  • Global Moderator
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 7333
Re: Pop! Smoke... but everything still works...
« Reply #15 on: June 15, 2018, 04:49:44 AM »

Maybe you were going so fast that a static electrical charge built up on the filter and it electrocuted itself and surprised your bike so much that is sneezed? ;)

If it doesn't do it again, then just let it be. No point starting a fight with your bike.
Logged
I used to be a sensitive, new age guy, but times have changed and now I am more of a caring, understanding, ninties type.

spit051261

  • Grinding the pipes
  • *****
  • Online Online
  • Posts: 1168
Re: Pop! Smoke... but everything still works...
« Reply #16 on: June 21, 2018, 08:07:26 AM »

No point starting a fight with your bike.
A fight you probably won't win .
Logged
2010  GT650R in the best colour RED

Pages: 1 [2]