korider.com | Hyosung Motorcycle Owners Forum

korider.com | Hyosung Motorcycle Owners Forum

  • June 19, 2019, 05:59:15 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to Korider.com!

Pages: [1]

Author Topic: help  (Read 360 times)

luson

  • Learner rider
  • **
  • Offline Offline
  • Posts: 57
help
« on: December 29, 2018, 09:34:42 PM »

I have a 2012 GV250 EFI. It was running fine until the fuel pump when out. It took me about 3 month to actually get the fuel pump on order. I received the blue pump. The old one was black. After replacing it, now it runs fine until it reaches 7500 RPM. It fluctuates it start fluctuating between 8000 and 7000. (up & down) If I give more acceleration it will go up to 10000 and stays there. It seems that it is misfiring. The plugs and the plug boots are new.
Logged

Register and log in and the Ads below will be gone! :D

BikeBandit.com

archaz

  • Learner rider
  • **
  • Offline Offline
  • Posts: 48
Re: help
« Reply #1 on: January 02, 2019, 09:44:52 AM »

Possibly an injector issue... maybe need cleaned. Did any debris make it from the pump or filter to the injectors? Hopefully it is not an electrical issue.
Logged

luson

  • Learner rider
  • **
  • Offline Offline
  • Posts: 57
Re: help
« Reply #2 on: January 02, 2019, 01:19:46 PM »

The old fuel pump strainer was clean when it was removed. There were not any type of trash or sediments when the fuel tank was emptied. I have put inside the tank on a previus tank filling injector cleaner. Beside those 2 issues the motorcycle runs fine. It does not misfire at 10k rpm it just does not goes heigher. It is not that I want to blow the engine up, it seems that it does have a problem. I am going to remove the spark plug cable and check how a good connection is between the spark plug boot and the spark plug cable. It may not be it but is that I do not trust the mechanics at these motorcycle locations. There is not a hyosung mechanics. I took it one time to the dealer were I bought it for a fuel leak 3 moth after I bought it and it came back with the fuel sending unit backward. I took it back and they could not figure out why it was not showing fuel at the gage. They replace the fuel sending unit and still not showing fuel at the gage. I had to fixed myself. Thank you for your advise.
Logged

Kiuvi599

  • Learner rider
  • **
  • Offline Offline
  • Posts: 40
Re: help
« Reply #3 on: January 11, 2019, 03:41:57 PM »

Check fuel pump presure

Sent from my SM-G955U using Tapatalk

Logged

luson

  • Learner rider
  • **
  • Offline Offline
  • Posts: 57
Re: help
« Reply #4 on: February 16, 2019, 01:22:24 AM »

The old fuel pump was defective but it took a good while to replaced. It could not used for almost 5 month because I was not sure. I don't like to take it to the shop because I do not trust them. After replacing the pump that when started to have the problem I replaced the plugs and checked to make the connection between the plug and the plug cable were good. The problem still there. After you guys suggestions I removed the fuel pump to recheck it. No problems found with it. Now I checked the wires connected to both coils and they had a lot of play I disconnected them and it had dirt like a loose electrical connection, kind of burned between contacts. Cleaned them and tightened the compression connectors. The problem is gone. :-). Thanks again
 :) :) :)
Logged

Kiuvi599

  • Learner rider
  • **
  • Offline Offline
  • Posts: 40
Re: help
« Reply #5 on: February 16, 2019, 01:38:38 AM »

That cool Im happy that you fix the bike

Sent from my SM-G955U using Tapatalk

Logged

umop-ǝpisdn

  • Global Moderator
  • Forum Addict
  • *****
  • Offline Offline
  • Posts: 7634
Re: help
« Reply #6 on: February 16, 2019, 06:57:19 AM »

That’s awesome news. Good on you for persisting
Logged
I used to be a sensitive, new age guy, but times have changed and now I am more of a caring, understanding, ninties type.

spit051261

  • Grinding the pipes
  • *****
  • Offline Offline
  • Posts: 1569
Re: help
« Reply #7 on: February 16, 2019, 07:23:21 AM »

Well done  ;)
Good to see someone here with the persistence to get it done without being spoon fed and starting up 20 other threads on the same fault , hoping for different answers  :o
Good on you  :)
« Last Edit: February 16, 2019, 07:25:52 AM by spit051261 »
Logged
2010  GT650R in the best colour RED

Cruisa

  • 2-Wheeled Nomad
  • Learner rider
  • **
  • Offline Offline
  • Posts: 60
Re: help
« Reply #8 on: March 08, 2019, 02:57:03 AM »

I know, right? Can you believe people on here actually try and ask people for help? The misguided fools.
Logged
I was going for the Peter Fonda look.
I ended up with the Dennis Hopper look.

Pages: [1]